Weblog

door Remy onder NewsVPS / Server Management | 0 comments

CentOS 5 en Ubuntu 12.04 niet meer ondersteund en geen updates meer

Vanaf deze maand zijn er twee grote Linux-distributies uit support, namelijk Ubuntu 12.04 en CentOS 5. In dit bericht gaan we in op de gevolgen hiervan en wat u kunt doen.

Linux support Lifecycle


Elke grote Linux-distributie, het besturingssysteem op uw VPS, ontvangt geregeld updates. De leverancier verzorgt deze en de ondersteuning gedurende een bepaalde periode. Voor sommige besturingssystemen kan dit enkele maanden tot jaren zijn zoals voor CentOS, Debian en Ubuntu LTS (Long Term Support).

Updates van uw besturingssysteem zijn noodzakelijk om beveiligingslekken tegen te gaan of te verhelpen en om nieuwe toepassingen te ondersteunen (bijvoorbeeld een databaseserver, ftp- en webserver). Elke server die niet is bijgewerkt, loopt het risico om gehackt te worden, dataverlies, misbruik (abuse) of schade op te lopen. Het updaten van uw server is dus noodzakelijk.

CentOS5 (release 2007), is met ingang van 31 maart 2017 gestopt met de ondersteuning en het uitbrengen van updates.
Ubuntu 12.04 LTS (2012), is met ingang van 28 april gestopt met de ondersteuning en het uitbrengen van updates.

Een compleet overzicht van de datums en support cycle van alle grote Linux-versies kunt u op deze website vinden https://linuxlifecycle.com/. Ubuntu specifiek heeft ook een lifecycle pagina, namelijk https://www.ubuntu.com/info/release-end-of-life.

Geen ondersteuning en updates meer?


Geen updates en geen support houdt onder andere in dat beveiligingslekken, zoals Heartbleed, niet meer gepatcht worden. U kunt dus geen beveiligingsupdates meer doorvoeren op uw VPS. Een server die niet is bijgewerkt qua systeem- of websitesoftware, wordt snel en makkelijk gehackt waardoor u dataverlies, misbruik (abuse) en schade kunt oplopen.

Ook is de software repository niet meer beschikbaar. Dit is de plek waar via de package manager, apt of yum, software vanaf wordt geïnstalleerd. De URL's zijn aangepast en met omwegen kan er nog steeds software geïnstalleerd worden, alleen is de beschikbaarheid hiervan niet gegarandeerd.

CloudVPS kan eveneens veel minder tot geen ondersteuning meer leveren op servers met oude, niet meer ondersteunde besturingssystemen. Bij onze service level agreement 2 zitten maandelijks updates vanuit ons inbegrepen, maar op getroffen servers kunnen we deze niet meer toepassen. Ook kan het zijn dat we bepaalde verzoeken niet meer kunnen uitvoeren doordat de software niet meer beschikbaar is.

Als u een server heeft die gebruikmaakt van deze besturingssystemen die nog ouder zijn dan de genoemde versies, bijvoorbeeld Ubuntu 10.04 of CentOS 4, dan is hierop hetzelfde van toepassing. De ondersteuning daarvan is al veel langer verlopen en het risico nog veel groter.

Wat moet u doen?


Uw server werkt nog en is ook beschikbaar. Aan de hosting van uw server vanuit onze kant zal niets veranderen. De server blijft op ons platform beschikbaar. Uw server loopt enkel een verhoogd risico op hacks en dataverlies doordat er geen updates meer zijn om deze te voorkomen. Denk hierbij aan een auto met een verlopen APK en bekende gebreken. Dit is wachten tot het mis gaat.

Via uw controlpanel kunt u controleren welke versie van Linux u gebruikt. Heeft u een server zonder controlpanel, dan kunt u het volgende commando via ssh gebruiken:

    cat /etc/redhat-release || lsb_release -a

 U ziet uitvoer als volgt:

    CentOS Linux release 5.7

 of

    Distributor ID: Ubuntu
    Description:    Ubuntu 12.04.5 LTS
    Release:          12.04
    Codename:     precise

U moet zo snel mogelijk alle data op de server migreren naar een server met een recenter besturingssysteem.. Voor CentOS is dat CentOS 7, voor Ubuntu is dat Ubuntu 16.04. Heeft u een controlpanel, dan kunt u hetzelfde controlpanel gebruiken indien beschikbaar.

Een zogenaamde ‘in-place’ upgrade raden wij ten zeerste af en ondersteunen we niet. Ten eerste  is een roll-back niet mogelijk. Ten tweede is het op ons Xen-platform niet gegarandeerd dat ‘in-place’ upgrades werken. CentOS heeft zelfs geen mogelijkheid om ‘in-place’ te upgraden. Indien u wel een ‘in-place’ upgrade uitvoert en die gaat mis, dan kunnen we geen ondersteuning bieden.

Voor een migratie vanaf uw huidige VPS dient u een nieuwe VPS te bestellen aangezien ‘in-place‘ upgrades niet mogelijk zijn. Deze VPS kunt u via onze website bestellen, de oplevering is meestal direct en automatisch. Het onderhoud en de uitvoer van de migratie dient u zelf uit te voeren en valt niet binnen de dienstverlening van CloudVPS of onder de SLA.

Migraties voor VPS’en die gebruikmaken van een controlepaneel (cPanel/DirectAdmin) zijn relatief eenvoudig uit te voeren via de hiervoor beschikbare documentatie.
 
Voor DirectAdmin:   https://help.directadmin.com/item.php?id=57
Voor cPanel:             https://documentation.cpanel.net/display/CKB/How+to+Move+All+cPanel+Accounts+from+One+Server+to+Another

Zie ook onze website voor meer informatie over migreren:
https://www.cloudvps.nl/klantenservice/knowledge-base/het-veilig-migreren-van-websites/

Indien u vragen heeft kunt u ten alle tijden contact opnemen met onze servicedesk, via email naar support@cloudvps.nl of telefoon via onze contactpagina.

Comments (0)

Laat een reactie achter

VPS Bestellen
VPS Bestellen